Sophos UTM 9.211003-304009 Up2date failed

Hatte heute ein Problem auf einer Sophos UTM220 beim Update von 9.211003 nach 9.304009 via Up2date Funktion.

Der Fehler:

2015:03:11-12:28:11 lxfw01 auisys[25578]: >=========================================================================
2015:03:11-12:28:11 lxfw01 auisys[25578]: id="371J" severity="error" sys="system" sub="up2date" name="Fatal: Version conflict: required version: 9.302002 <=> current version: 9.211003" status="failed" action="install" package="sys"
2015:03:11-12:28:11 lxfw01 auisys[25578]: 
2015:03:11-12:28:11 lxfw01 auisys[25578]:  1. main::alf:75() auisys.pl
2015:03:11-12:28:11 lxfw01 auisys[25578]:  2. main::perform_work:1068() auisys.pl
2015:03:11-12:28:11 lxfw01 auisys[25578]:  3. main::auisys_prepare_and_work:560() auisys.pl
2015:03:11-12:28:11 lxfw01 auisys[25578]:  4. main::top-level:37() auisys.pl
2015:03:11-12:43:02 lxfw01 audld[27848]: Starting Up2Date Package Downloader
2015:03:11-12:43:02 lxfw01 audld[27848]: patch up2date possible
2015:03:11-12:43:10 lxfw01 audld[27848]: id="3701" severity="info" sys="system" sub="up2date" name="Authentication successful"
2015:03:11-12:43:10 lxfw01 audld[27848]: id="3707" severity="info" sys="system" sub="up2date" name="Successfully synchronized fileset" status="success" action="download" package="avira3"
2015:03:11-12:43:11 lxfw01 auisys[27892]: Starting Up2Date Package Installer
2015:03:11-12:43:11 lxfw01 auisys[27892]: Searching for available up2date packages for type 'sys'
2015:03:11-12:43:11 lxfw01 auisys[27892]: Installing up2date package file '/var/up2date//sys/u2d-sys-9.302002-303002.tgz.gpg'
2015:03:11-12:43:11 lxfw01 auisys[27892]: Verifying up2date package signature
2015:03:11-12:43:12 lxfw01 auisys[27892]: Unpacking installation instructions
2015:03:11-12:43:12 lxfw01 auisys[27892]: >=========================================================================
2015:03:11-12:43:12 lxfw01 auisys[27892]: id="371J" severity="error" sys="system" sub="up2date" name="Fatal: Version conflict: required version: 9.302002 <=> current version: 9.211003" status="failed" action="install" package="sys"
2015:03:11-12:43:12 lxfw01 auisys[27892]: 

  (mehr …)

Sophos UTM 220 A/S HA – Up2date failed on slave

Gestern bei einem Kunden ein Update von zwei Sophos UTM 220 gemacht, welche im A/S HA Betrieb laufen. Normalerweise funktioniert so ein Update im HA problemlos, zuerst wird der slave hochgepatched, reloaded und sobald dieser wieder „active“ ist, macht das System einen Failover und upgraded den Master.

Nun, nachdem ich den Up2Date Prozess über den Webadmin angestossen habe, fand ich folgendes Szenario vor:

Jegliche Versuche den Prozess nochmals über den Webadmin anzustossen schlugen fehl. Über das GUI konnte man das Problem nicht mehr lösen.

Let’s troubleshoot

(mehr …)