Hacking Cisco Prime Syslog severity

Cisco Prime Infrastructure bietet eine Syslog Server Funktion, der Umfang ist jedoch begrenzt auf Serverities bis Stufe 3.
Über das GUI gibt es leider keine Möglichkeit diese Limitation zu umgehen, geht man jedoch via Console/SSH auf die Rootshell, kann man das entsprechende Konfig File editieren um weitere Stufen frei zuschalten.

 Zugriff auf Rootshell:

vvmwlc21/admin# root
Enter root password :
Starting root bash shell …
ade #

 Ausgabe des Syslog Konfig Files:

ade # cd /opt/CSCOlumos/conf/
ade # ls syslog_sev_filter.xml

ade # cat syslog_sev_filter.xml

<expression op=’OR‘>

<!– Error –>
<condition field=’severity‘ op=’EQUALS‘ value=’0′ />
<condition field=’severity‘ op=’EQUALS‘ value=’1′ />
<condition field=’severity‘ op=’EQUALS‘ value=’2′ />

</expression>
ade #

 

Um das Konfigfile zu editieren besteht die Möglichkeit dies mit dem Texteditor „VI“ zu tun. VI punktet allerdings nicht gerade mit Benutzerfreundlichkeit, deswegen ist es gegebenen Falls sogar einfacher sich das File via FTP runter zuladen, lokal zu editieren und wieder hochzuladen.

(mehr …)

Upgrading Cisco Prime Infrastructure 1.3 to 2.0

 Cisco Prime Infrastruktur ist ein tolles Tool. In der Version 2.0 werden nun endlich auch die neuen WLAN Controller (5670, 3850, 3650) mit dem Converged Access Ansatz unterstützt. Vor dem Upgrade sollte man nicht zuviel Angst haben, dennoch sollte man die Release Note sorgfältig durchlesen.

 Nebst den „Supported Devices“ sind wohl die Upgrade Requirements die wichtigsten Punkte die man beachten muss

 

You can upgrade the following NCS/Prime Infrastructure 1.x versions to Prime Infrastructure 2.0:

  • 1.1.1.24 with patch ncs_1_1_1_24-Update.13.4.tar.gz
  • 1.2.1.12 with patch PI_1_2_1_12-Update.1.0.tar.gz
  • 1.3.0.20 with patch PI_1_3_0_20-Update.1.12.tar.gz and/or PI_1_3_0_20_Update.4-16.tar.gz
  • 1.2.1.12 (migrated from 1.2.0.103) with patch PI_1_2_1_12u-Update.1.tar.gz

The following NCS/Prime Infrastructure 1.x backups can be restored to Prime Infrastructure 2.0:

  • 1.1.1.24 with Patch ncs_1_1_1_24-Update.13.4.tar.gz
  • 1.2.1.12 with Patch PI_1_2_1_12-Update.1.0.tar.gz
  • 1.3.0.20 with patch PI_1_3_0_20-Update.1.12.tar.gz and/or PI_1_3_0_20_Update.4-16.tar.gz
  • 1.2.1.12 (migrated from 1.2.0.103) with patch PI_1_2_1_12u-Update.1.tar.gz

The following NCS/Prime Infrastructure 1.x versions cannot be upgraded or restored to Prime Infrastructure 2.0:

  • 1.4
  • 1.2.0.103
  • 1.1.0.58 and earlier versions

For detailed information about the application upgrade, see the following URL:

http://www.cisco.com/en/US/docs/net_mgmt/prime/infrastructure/2.0/quickstart/guide/cpi_qsg.html#wp56675

  (mehr …)